WordPress 4.3.1 est disponible

17 Sep, 2015  - écrit par  dans Le Bar de Gandi

Une nouvelle release de WordPress, la version 4.3.1, vient corriger 2 vulnérabilités de XSS (Cross Site Scripting) et une vulnérabilité au niveau de la gestion des privilèges permettant, par exemple, à un utilisateur non-autorisé de créer des articles privés.

Il est temps de vérifier si les mises-à-jour automatiques de votre WordPress sont au point, ou de lancer une mise-à-jour manuellement. Vous avez en effet tout intérêt à boucher les 3 vulnérabilités et les 26 bugs que la version 4.3.1 de WordPress vient corriger.

Deux sont des vulnérabilités de XSS (Cross Site Scripting) et concernent le traitement des balises « shortcode » dans les versions 4.3 et antérieures, ainsi que la page de la liste des utilisateurs. Le dernier est un problème de gestion des privilèges où, dans certains cas, un utilisateur non-autorisé pouvait publier des articles privés et les marquer comme « sticky ».

Même si cette version n’apporte pas de nouvelles fonctionnalités, elle vient tout de même corriger 26 autres bugs de la version 4.3. En tout, se sont 64 fichiers qui ont été modifiés pour améliorer différents aspects du CMS le plus populaire au monde, de l’interface à son fonctionnement interne.

À vos consoles d’administration, donc ! Ou rendez-vous sur le changelog officiel pour avoir de détails (en Anglais): https://codex.wordpress.org/Version_4.3.1