HVM 已支援新 Linux kernel (3.12.45 及 3.18),AUFS 即将停止支援

08.13.2015  - 作者  在 云端

我们已更新 HVM 的 Linux kernel 3.12 至 3.12.45,也发布了新版 3.18。
新版不会支援 AUFS,且可能会要求部份用户做些修改。

从8月10日起,在 HVM 上建立或重新启动的伺服器将会自动采用 3.12.45 版的 kernel
用户可以指定使用 3.18 版,或是自订的版本。

请注意,新版的 kernel 皆不支援 AUFS。
Docker 使用者更需要留意此讯息,因为 AUFS 有很长一段时间都是预设的档案系统。

如要在新版之下继续使用 Docker,使用者必须先升级客户端及映像档以使用不同的档案系统,
如 BTRFS 或 overlayfs (只能在 3.18 版中使用)。

如欲使用 3.18 版,您可以执行以下的 Gandi CLI 指令:

$ gandi disk update  --kernel "3.18-x86_64 (hvm)"

您也可以在网站的介面上更改核心版本 (英文说明):
http://wiki.gandi.net/en/iaas/references/disk/advanced-boot 

完成操作之后,请重新启动伺服器,并更新软体及 kernel 模组 (英文说明):
http://wiki.gandi.net/iaas/references/server/kernel_modules

用户若想要自订 kernel ,可以参考我们的 Wiki 说明 (英文):
https://wiki.gandi.net/fr/iaas/references/server/hvm

关于 kernel 的历史更新记录,您可以参考我们的 Changelog:
https://wiki.gandi.net/fr/iaas/references/server/kernel_changelog?&#section312