Simple Hosting 已支援 PHP 5.6

02.15.2016  - written by  in 简易代管

Simple Hosting 现已支援 PHP 5.6 版本,并将其设定为建立 instance 时的预设选项。如果您想用 PHP 5.4,可以在建立 instance 时从清单中选取。

我们发布了一篇教学文章 (英),帮助您从 PHP 5.4 转移至 PHP 5.6,您可以从文章中了解一些转移及测试的技巧。

除此之外,我们计划在2016年3月22日发布一个功能,让 PHP 5.4/MySQL 的使用者可以自动升级。而其他版本的使用者则仍需手动操作版本升级。

如果您在转移的过程中遇到任何问题,欢迎与我们的客服团队联系。

PHP 5.6 版的 instance 是在使用 Debian 8 (Jessie) 的系统映象档上执行,预期会有更多创新的功能。如您有任何的使用心得,请与我们分享!


Bonus: 套件相依性管理工具 Composer

从现在起,您可以使用 PHP 最受欢迎的套件相依性管理工具 Composer 来简单地安装管理套件 (支援 PHP 5.6 及 5.4 的 instances)。

套件相依性管理工具可让网页开发者更轻松地管理包含第三方程式码的专案。这类工具提供一种简单的方式,协助列出应用程式中的外部相依性套件,并支援下载、安装正确的档案。

Simple Hositng 已支援 Node.js、Python、Ruby 的套件相依管理工具,分别为 npm、pip、及 bundler。再加上 PHP 的 Composer,我们现已提供所有 instance 类型的现代化开发流程。

使用 Composer 的第一步,请参考线上文件及范例