Actualización importante en nuestros kernels

05.02.2016 - written by  in Cloud

 

3.18 es el nuevo kernel por defecto en HVM

El kernel Linux 3.18 es el nuevo kernel por defecto en la plataforma HVM, reemplazando la versión 3.12.

La utilización de Docker es ahora más simple en HVM, ya que el kernel 3.18 soporta el driver de almacenamiento “overlay”. Encontrarás más información en la documentación de Docker en el Wiki.

 

El kernel 3.10 con soporte AUFS queda obsoleto

El 10 de marzo 2016 actualizamos el kernel 3.10, pasando a la versión 3.10.96. Esta versión incluye actualizaciones de seguridad (con CVE-2016-0728), pero implica el fin del soporte AUFS.

Si quieres seguir utilizando la tecnología AUFS, puedes migrar a la plataforma HVM. Entonces podrás utilizar el kernel de tu elección con las opciones “raw” y “grub”.

Los usuarios de Docker que no necesitan AUFS pueden migrar hacia HVM y optar por el kernel 3.18, que soporta el driver de almacenamiento “overlay” por defecto.

Puedes consultar nuestro Wiki para migrar a HVM y saber más sobre la utilización de Docker en nuestra plataforma.

 

Actualizaciones de seguridad para los kernels 3.2, 3.12 y 3.18

Los kernels 3.2 (plataforma Xen), 3.12 y 3.18 (plataforma HVM) han sido actualizados a las versiones 3.2.76, 3.12.53 y 3.18.26, respectivamente.

Puedes reiniciar los servidores para utilizar las nuevas versiones.

 

Los kernels compatibles con “grsecurity” quedan obsoletos

El 10 de marzo 2016, suprimiremos los kernels compatibles con “grsecurity” (“2.6.32-x86_64-grsec” y “3.2-x86_64-grsec”) de nuestra plataforma, debido a los cambios anunciados y a su política de distribución.

A partir de esta fecha, las versiones “non-grsec” de los kernels serán utilizadas por defecto. Hasta este momento, puedes utilizar un nuevo kernel y preparar la migración hacia la plataforma HVM. Si quieres seguir utilizando las funcionalidades grsecurity, puedes configurar tu propio kernel y utilizar las opciones “raw” o “grub”.